[a / b / c / d / e / f / g / gif / h / hr / k / m / o / p / r / s / t / u / v / vg / vr / w / wg] [i / ic] [r9k / s4s / vip / qa] [cm / hm / lgbt / y] [3 / aco / adv / an / asp / bant / biz / cgl / ck / co / diy / fa / fit / gd / hc / his / int / jp / lit / mlp / mu / n / news / out / po / pol / qst / sci / soc / sp / tg / toy / trv / tv / vp / wsg / wsr / x] [Settings] [Search] [Home]
Board
Settings Home
/g/ - Technology



Thread archived.
You cannot reply anymore.



File: 1521042669683.jpg (109 KB, 1632x1652)
109 KB
109 KB JPG
I was copying files from an xbox 360 to my usb. Dumbass bro switched off the xbox and my usb is now corrupted. Won't show up in windows but in linux lsblk -a shows sdb with 0B of storage. Am i fucked?
>>
Yes
>>
>>66337919
the disk is also seen in disk management in windows
>>
dd if=/dev/zero of=/dev/sdx
mkfs.fat
>>
>>66337998
I want the pictures on it bro
found out kinect adventures was spying on me while jumping
>>
bump
niggers please help
>>
that's what you get for using 20 year old console in 2018
>>
>>66337896
> xbox 360
>>
Have you tried fsck?
>>
Just use gparted to delete the old partition and make a new one nibba that will give you your space back

If you want to recover your stuff dont write anything in the USB after making the new partition and use a data recovering software like data easeus (paid but can be cracked)
>>
>>66338181
kys faggot
>>66338246
no. how do i set the target directory for it? I can't even mount the usb
>>
does op want his files back or is this a salvage mission for the flash drive?
>>
>>66338348
I want the files back.
>>
>>66338375
Im assuming the flash drive was fat32 have you tried running utilities like testdisk to see if it can find anything on the drive
>>
File: 1528533829448.jpg (67 KB, 675x720)
67 KB
67 KB JPG
>>66337896
Flash it using an arduino with an on-chip programmer/debugger (e.g. atmel ice).

Other than that you're pretty fucked.
>>
>>66338424
Nigger it won't show up normally. I run lsblk -a and i see a blank sdb with 0B
and i think the xbox file system was fat32
>>
>>66338306
Have you RTFM?
>filesys can be a device name (e.g. /dev/hdc1, /dev/sdb2)
>>
>>66337896
Make sure to punch your brother
>>
>>66338489
please be patient i am kinda retarded with this thing
How can i find the usb's letter? AFAIK it isn't sda2 or any sda. i can confirm the letter is sdb
>>
File: 541f3fa49db55.jpg (15 KB, 208x256)
15 KB
15 KB JPG
>>66338453
If thats truly the case then it looks like the controller got nuked by the xbox other than what is suggested in >>66338426 your options are pretty limited you could try transplanting the flash chip to an identical working drive if the files are that valuable to you or try recovering the original files from the xboxs hdd
>>
>>66337896
Is the Xbox drive corrupted? Can you not just initiate the transfer again?
>>
>>66338570
>original files from the xboxs hdd
I used transfer items. pretty retarded desu to not add copy instead
Either way i'm on my way to a computer shop to try and fix my shit. brb and thanks bros
>>66338587
thankfully no the xbox is still fine
>>
>>66337896
WTF is the problem? Just restore from your backup. Oh you don't have one? What a retard you must be.

just send it do a data recovery specialist if you need the data that bad.
>>
>>66338536
Post lsblk output.
>>
>>66338252
>the real solution got no replies by OP get again
Never change, /g/
>>
your files are good as gone, retard
>>
>>66338651
I aint taking any chances formatting stuff. And the thing is probably fried
>>
>>66338672
I'll spell it out just this once.
>your partition table is fucked
>you need to fix it, so your device's partitions can be read and mounted
>you need to recover the data afterwards and /before/ writing to partition.
No data is truly lost, merely marked for overwriting with new data.
Don't overwrite your data and you can recover it.
Don't format it.
Don't do anything except fix the partition table, the. Recover the data. Then format it.
>>
>>66338798
Then how the hell can i fix the table when the thing isnt even detected
Also computer shop is closed for the day. lazy bastards
>>
>>66338857
reading comprehension you fucking mongo
>>
>>66338906
I don't know how to recover the data it's not even showing in testdisk
>>
>>66338927
Are you in windows?
If so, open cmd as administrator, run diskpart, select the flash "disk" and type clean.
That should give you a new partition table.
>>
>>66338649
It's showing sda1 to sda6 (main disk + windows partitions)
and then there's sdb which is literally 0
>>66338956
dude i want my photos back. this will nuke the usb. And i can do both windows and gnu/linux
>>
>>66338983
It won't nuke it, it will just clear the partition table, then you'll be able to see it in testdisk.
>>
>not just taking the harddrive out of the xbox hueg
you should know that something that old has a decent chance to fuck something up retard
>>
File: images.jpg (18 KB, 471x312)
18 KB
18 KB JPG
>>66338181
>2005 was 20 years ago
>>
>>66338010
i ain't yo bro, homie
>>
File: 980x.jpg (60 KB, 400x481)
60 KB
60 KB JPG
>>66337896
your bro needs to be given for an adoption. you know it's the only choice, anon
>>
open up the memory with eclipse ide and see if you can't put the puzzle together
>>
(in linux)
>go to terminal
$/> sudo apt install gparted
$/> sudo gparted
a window will open
>click the box that says /dev/sda to switch to /dev/sdb
> click 'Create Partition Table...' in the Device dropdown menu
once Partition table is created:
>click "New" button
>set File system to fat 32 and press Add
>Click 'Apply' button
>wait until loading bar finishes to close gparted and remove usb.
Congradulation! USB is good as new. And empty.
>>
>>66340704
I ain't your homie, champ.




Delete Post: [File Only] Style:
[Disable Mobile View / Use Desktop Site]

[Enable Mobile View / Use Mobile Site]

All trademarks and copyrights on this page are owned by their respective parties. Images uploaded are the responsibility of the Poster. Comments are owned by the Poster.